TORONTO TUNER SYNDICATE
Welcome to Toronto Tuner Syndicate
TTS represents the Toronto tuner scene as a whole . No matter what other club you rep or ride you rep we have a spot for you in TTS . Take a minute to check out our club sponsors and don't forget to register for full TTS content .

Passenger side headlight - no power!

View previous topic View next topic Go down

Passenger side headlight - no power!

Post by stitchflip on Sun Oct 31, 2010 1:37 pm

so as title says, my passenger side has no power..
I thought my HID bulb or ballast got toasted, but tried to plug in OEM bulbs and even that won't fire up.
can anyone direct me to where I can find the fuse (if there is one) of headlights..I hope the left and right headlight has separate fuses or else it's a wiring problem and that's when I'm fucked!

thanks!
avatar
stitchflip
TTS VIP

Location : Toronto
Join date : 2009-09-29
Posts : 324

Back to top Go down

Re: Passenger side headlight - no power!

Post by Juice on Sun Oct 31, 2010 2:14 pm

Should be in one of two places ... most likely that big black box on the driver's side under your hood. Pop it off, the relay/fuse guide is on the underside of the cover.
Otherwise, the fusebox is behind that weird useless flap below and to the left of the steering wheel inside the car ... the flap has the guide on the backside, but those fuses are a pita to get to.

_____________________________________

www.bathalastudios.com
www.bestphotographersintoronto.com/
avatar
Juice
TTS Moderator

Location : Toronto
Age : 36
Join date : 2010-03-05
Posts : 2292

Back to top Go down

Re: Passenger side headlight - no power!

Post by stitchflip on Sun Oct 31, 2010 3:59 pm

i just came back from checkin the fuses in the engine bay, all the fuses that has the "headlight" drawing looks fine...didn't check the fuse right below the steering wheel..

there's this one big fuse tho (engine bay) that has the headlight logo too but not sure what it was for and can't tell if it's busted or not..

someone told me the fuse for the headlights is only one - thus if it's a fuse problem, both lights wont work - but thats not the case with my shitty car!

might head down to Mid-Toronto again tomorrow to get it checked.

15% discount? lmao
avatar
stitchflip
TTS VIP

Location : Toronto
Join date : 2009-09-29
Posts : 324

Back to top Go down

Re: Passenger side headlight - no power!

Post by just G on Mon Nov 01, 2010 10:51 am

just put your stock bulbs in and take it into any dealership. warranty will cover that. just say no if they as if u installed hid's.
avatar
just G
TTS Moderator

Location : Downtown T.O.
Age : 31
Join date : 2009-09-27
Posts : 2332

Back to top Go down

Re: Passenger side headlight - no power!

Post by stitchflip on Mon Nov 01, 2010 11:16 am

yeah, that's what I'm gonna do...
but I think Scarb mitsu already know that I have HIDs..
and Dave (mid-toronto) now knows it! lmao
avatar
stitchflip
TTS VIP

Location : Toronto
Join date : 2009-09-29
Posts : 324

Back to top Go down

Re: Passenger side headlight - no power!

Post by stitchflip on Mon Nov 01, 2010 11:06 pm

yup, it was a fuse problem..got this sorted out...
new problem: one of my HID bulbs is out - I'm like the unluckiest person right now!
😢
avatar
stitchflip
TTS VIP

Location : Toronto
Join date : 2009-09-29
Posts : 324

Back to top Go down

Re: Passenger side headlight - no power!

Post by egltalon_esi-turbo on Mon Nov 01, 2010 11:20 pm

oh you found the fuse. great.
i wouldn't say anything about the "mods" if you take it in. or not claim warranty just because of a mod if its not related.
But if the mod is causing the problem you cant expect warranty to cover it. understand what i mean.
avatar
egltalon_esi-turbo
TTS Rookie

Join date : 2010-07-27
Posts : 49

Back to top Go down

Re: Passenger side headlight - no power!

Post by stitchflip on Tue Nov 02, 2010 12:13 am

yeah, apparently the 2 fuses that I chose not to check are the one that was shot..
i didn't think it was the HIDs that caused the fuse to blow..it was my fault coz I kept turning it on/off, unplugging bulbs to switch them and stuff.
avatar
stitchflip
TTS VIP

Location : Toronto
Join date : 2009-09-29
Posts : 324

Back to top Go down

Re: Passenger side headlight - no power!

Post by Juice on Tue Nov 02, 2010 10:33 am

Glad you got it sorted out. Was it a fuse in the engine bay or in the car?
I've had to mess with my fuses a few times already ... after our first Shannonville trip, my 12v plug by my dash stopped working, and the Lancer's fuse box wasn't designed for people without tiny hands.

_____________________________________

www.bathalastudios.com
www.bestphotographersintoronto.com/
avatar
Juice
TTS Moderator

Location : Toronto
Age : 36
Join date : 2010-03-05
Posts : 2292

Back to top Go down

Re: Passenger side headlight - no power!

Post by stitchflip on Tue Nov 02, 2010 11:13 am

it was in the engine bay..if you look at the cover, you could see a row of 4 fuses, but when I looked at the fuses, there's only 2 installed and one of them was busted..

but now i have a busted HID bulb...fml
I need to get 1 6000k bulb - if anyone has an extra 9006 6k HID bulb lying around?
avatar
stitchflip
TTS VIP

Location : Toronto
Join date : 2009-09-29
Posts : 324

Back to top Go down

Re: Passenger side headlight - no power!

Post by Juice on Tue Nov 02, 2010 11:26 am

Actually ... I just bought a set of 6000k bulbs from G, and when trying to test them, I broke one of the little tabs on one bulb. I think for safety sake I should just replace that bulb ... in which case, I'd have a spare 6000k
What kind of bulb do you need? D2S?

_____________________________________

www.bathalastudios.com
www.bestphotographersintoronto.com/
avatar
Juice
TTS Moderator

Location : Toronto
Age : 36
Join date : 2010-03-05
Posts : 2292

Back to top Go down

Re: Passenger side headlight - no power!

Post by stitchflip on Tue Nov 02, 2010 11:54 am

hmm..not sure...lemme check the box later and i'll get back to you.
avatar
stitchflip
TTS VIP

Location : Toronto
Join date : 2009-09-29
Posts : 324

Back to top Go down

Re: Passenger side headlight - no power!

Post by Juice on Mon Nov 08, 2010 3:40 pm

hey Stitch! Here's a guide I came across on how to run a wire into your car without drilling through the firewall (you still have to drill, but it's through a rubber grommet, which will seal around the wire anyway.

http://forums.evolutionm.net/evo-x-how-tos-installations/374707-evo-x-boost-gauge-install-no-splicing-no-firewall-drilling-pics-vid-clean-hell.html

_____________________________________

www.bathalastudios.com
www.bestphotographersintoronto.com/
avatar
Juice
TTS Moderator

Location : Toronto
Age : 36
Join date : 2010-03-05
Posts : 2292

Back to top Go down

Re: Passenger side headlight - no power!

Post by stitchflip on Tue Nov 09, 2010 1:35 am

sweet! that looks awesome, yo!
thanks!
avatar
stitchflip
TTS VIP

Location : Toronto
Join date : 2009-09-29
Posts : 324

Back to top Go down

Re: Passenger side headlight - no power!

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum